Emacs24 in Debian Wheezy

From banana_wiki
Revision as of 15:19, 10 April 2014 by Bananafish (talk | contribs) (Created page with "Debian currently only packages emacs23, to get the latest version of emacs on Debian Wheezy we just have to do the following steps. == Install dependencies == <pre>apt-get i...")
(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Debian currently only packages emacs23, to get the latest version of emacs on Debian Wheezy we just have to do the following steps.

Install dependencies

apt-get install libxaw7-dev libxpm-dev libpng12-dev libtiff5-dev libgif-dev libjpeg8-dev libgtk2.0-dev libncurses5-dev git autoconf automake
apt-get build-dep emacs

Get emacs source

wget http://ftp.gnu.org/gnu/emacs/emacs-24.3.tar.gz

Compile and install emacs

tar zxvf emacs*
cd emacs *
./autogen.sh
./configure --prefix=/opt/emacs24
make
make install